Slow searches from api.fontawesome.com
Incident Report for Fort Awesome
Resolved
We've deployed the fix for this and searches should be speedy fast once again for all queries.
Posted Sep 06, 2022 - 21:43 UTC
Identified
We've identified the root cause of this and are working to address a fix. The impact of this issue is low enough that we're going to deploy the fix next week (Sep 6th or after).

We'll be keeping an eye on it through the weekend to make sure that the situation doesn't degrade.
Posted Sep 02, 2022 - 16:42 UTC
Update
We've released version 4.3.1 of the WordPress plugin, increasing the network request timeout to allow those longer-running searches to complete.

Continuing to work on the root cause to improve performance for these slower searches.
Posted Sep 01, 2022 - 23:55 UTC
Investigating
We've seen increased response times from the GraphQL API server for some queries. This impacts primarily the Font Awesome WordPress plugin and the icon chooser user interface. Search may be very slow or may actually be failing altogether. At this time the only impact is for WordPress site admins who are using the icon chooser to select icons as they build or manage content. It does not affect the performance of the public-facing sites.

We have ideas on the root cause but still need to investigate to come up with a fix.
Posted Sep 01, 2022 - 21:27 UTC
This incident affected: api.fontawesome.com.