Intermittent failures when trying to sign up for a free account on fontawesome.com/start
Incident Report for Fort Awesome
Resolved
This appears to be specific to some edge cases for certain customers. We don't really consider this a system-wide issue and are going to handle them one-at-a-time as they come in.

That being said: reach out to use at hello@fontawesome.com if you are experiencing issues.
Posted Apr 13, 2022 - 21:41 UTC
Investigating
We are currently investigating this issue.
Posted Apr 13, 2022 - 17:38 UTC
This incident affected: fontawesome.com.